Circle 2.1 Beta Links Inside


#1

Hi @CircleBetaTesters ,

How I think we should manage it is that when you find bugs, please post a bug report in the “Bug Report Thread”

What we will do then is verify the bug and create a bug ticket and post a topic with the bug, details, status etc. We’ll then work our way through them here one by one and move towards release beta2

  1. Launch and install Circle 2.1 Beta.
  2. Try it out as much as you can.
  3. If you hit a bug, then go to the forum and check if the is already created in its own thread. If so you can still report the bug in the “Bug Reporting Thread”, just state the name of the bug you think it is.
  4. We’ll keep an eye on everything here and then start working through verified bugs, developing fixes etc.

Mac OS-X:
http://www.futureaudioworkshop.com/downloads/Circle-2.1.0.Beta2-setup.dmg

Windows:
http://www.futureaudioworkshop.com/downloads/Circle-2.1.0.beta.2-32bit-setup.exe
http://www.futureaudioworkshop.com/downloads/Circle-2.1.0.beta.2-64bit-setup.exe

Change logs
Beta 1

  • Updated audio and graphics library
  • Updated AAX library
  • Fixed MIDI CC control crash
  • Fixed application window shading bug on Mac standalone
  • Refreshed internal window graphics
  • Curved application border on Mac standalone
  • Updated custom titlebar on Windows standalone

Beta 2

  • Custom titlebar restyling (Windows)
  • Fixed install path on (No presets / wavetables bug) (Windows)
  • Fixed interface background glitch (Windows)
  • Further graphics fixes
  • Fixed crash on close (Mac)
  • Fixed invalid activation file
  • Fixed qwerty musical keyboard repeat issue

Calling all beta testers!
Calling all beta testers!
Calling all beta testers!
Share Your Music!
#2

#3

I installed Circle 2.1 but it asks me an activation code that I don’t have.

Can you send me one, please ?

Or must I try it without ?

Sincerely yours

Yann


#4

I notice that the UI is small on Retina Display, and I don’t find how I can set it bigger.

Have you think to update Circle for retina display ?

As I use a lot U-HE synths, I used to have a good UI display on my 5K retina display of 27 inch.

Sincerely yours

Yann


#5

I continue my discovery…

There’s no presets. Is it normal ?

There’s no wavetables on OSC and when I choose wave 1 a window appear with nothing and I can’t draw nothing. And there’s no sound before I chose analog or vps.

So wavetables for now is very unusefull !

Sincerely yours

Yann


#6

Installed fine on Mac, but overwrote the original, so all I have now is the Beta. Are there specific features you want us to test, or at least a list of changes?


#7

@jcrystal, if you can have a general check around and if you find issues please post them in the bug reporting thread. We’ll then go


#8

Got the same issue… need an activation code.


#10

@Hugh_FAW

Hello. Requesting an activation code.

Thanks


#12

I’m also looking for an authorization code. I’ve hit an issue, but it might be related to the plugin being in demo mode. Thanks!


#13

the synth it’s amazing,

its the best in town.

the sounds resemble those in electon digitakt, the original sounds of it.

I come back with more impressions tomorrow!

love you , great job!!


#14

I installed the demo version of the site after I put the beta version and it worked!!

tnx again !!


#15

Hello, i also request an activation code. Thx


#16

Can you also see not see any wavetables / presets? Please continue finding bugs in demo mode for a while then we’ll look at sending a code.


#17

Please help us find some bugs using demo mode first, then we’ll get a code over!


#18

What issue are you experiencing? Please post in the bug reporting thread. If you could help us find some bugs using demo mode first, then we’ll get a code over.


#19

Thanks for the kind words! Looking forward to your feedback and bug reports.


#20

Please help us find some bugs using demo mode first, then we’ll get a code over!


#21

Please help us find some bugs using demo mode first, then we’ll get a code over.


#22

Please, could you post us some screenshots to show the comparison?

(In the bug reporting thread)